[Howto] Using newest flash in Konqueror in Fedora

Using newest flash in Konqueror in Fedora
Recent flash plugins didn’t work with newer Konqueror versions. But now the Fedora-KDE team released new KDE packages with support for the newest flash in Konqueror.

For quite some time now the newer flash plugins didn’t work with Konqueror: they required direct Xembed support which was not provided by Konqueror. As a result most Konqueror users sticked to the latest flash plugin that still supported the old-style Window passing. Some newer features were missing, but the rest worked.

However, recently several problems and vulnerabilities were found in the old flash plugin versions – some of them quite serious. As a result the flash plugin had to be updated or deactivated in Konqueror.

In the meantime the KDE project reacted and update the nspluginviewer library to support direct Xembed. The support is not perfect yet but works. And now the KDE-Fedora team took that code and patched the current kdebase and kdelibs: Konqueror can now use the newest flash plugins.

The updates are still in testing and therefore must be installed via

yum --enablerepo=updates-testing update kdebase kdelibs

But: keep in mind that this is still non-perfect code! There are reports that 86_64 could run into trouble of some kind. But you can help improving the packages by simply testing them and report all problems in the corresponding bug report.

8 thoughts on “[Howto] Using newest flash in Konqueror in Fedora”

  1. > “the KDE project reacted”

    Or rather a Novell/SUSE engineer made the patch. Fedora can only earn credit for including a patch with known troubles.

  2. AdamT, do you use a recent flash version or an older one?

    Anonymous: So? The KDE-developers at Novell/Suse are also part of the community. I don’t see the error in my statement.

  3. Actually the bit about missing XEmbed support isn’t fully correct.

    Konqueror has always been using XEmbed to make the nspluginviewer window part of the rendering, what has been missing is support for the new Netscape plugin API which uses XEmbed directly.

    Shows nicely how proprietary software development works. They will whine instantly about backward compatability if some API they depend on gets a newer version, but will without hesitation break compatability even within the same major version of their software.

Comments are closed.